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Xero Integration 
 
Paybiz integration with Xero to seamlessly link a tenant company in Xero with a Paybiz application company. 
This allows the interchange of Debtor (Xero Contact), Debtor Invoice (Xero Invoice) and Receipt (Xero Payment) 
information. 
 
Paybiz behaves as the MASTER for Debtor, Contact and Invoice information. 
 

• Debtor and Invoice information are sent from Paybiz to Xero. 
 

• Payments received in Xero are returned to Paybiz and are automatically allocated. 
 
The General Ledger optional module is required for Xero Integration. 
 
 

Notes / Tips 
 
Synchronisation: 

• We recommend running the Xero synchronisation daily overnight. 
This means that changes can be made on the day the job was invoiced without any issues in Xero. 

 

• Expired Token: 
The Xero Authorised Token Key expires if the synchronisation does not run for 14 days or more. 
To refresh, double click or hit F8 in the Xero Authorised Token field in Company Details > Xero tab 
Choose the token to Refresh, then proceed as per the instructions in Company Details – Configure the 
Connection to Xero. 

 
 
Debtors: 

• The Debtor Account No is sent from Paybiz to Xero and stored against the Xero Contact. 
The Xero Client ID is returned from Xero to Paybiz and stored against the Paybiz Debtor. 
 

• Only the first email on the Debtor is sent to Xero. 
 

• Use the Debtor Contacts to create Contact Persons in Xero so the invoice can be sent to multiple email 
addresses in Xero. 

 
 
Invoices: 

• Once an invoice has been sent to Xero, it will show an External ID at the bottom of the Notes tab on the 
Debtor Invoice screen. 
 

• You can add this field to your columns in the Debtor Invoice lookup screen so you can easily see which 
invoices have/have not been sent to Xero. 
Go to Debtors > Debtor Invoices 

o Right click on the column header, eg on the Allocated header, and choose Insert Column 
o Locate External Identifier and double click or Pick 
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• There is a log in File > System > System Functions. Click the View System Function Log button at the 
bottom right of the screen. Choose the last Xero Interface Synchronisation log to see the logs for the 
scheduled sync. 
 

• Paybiz invoices have an Approved setting. 
Only Approved invoices are be sent to Xero. 
Paybiz has invoices Approved by default, but you can change this in File > Company > Company Details > 
Constants tab > Approve Debtor Invoices by Default 
 

• To disable sending of a single invoice manually Un-Approve an invoice before the synchronisation runs. 
Simply open the Debtor Invoice screen and turn the Approved slider off. 
Turn it back on when you want it to be sent to Xero. 
 

• Invoices are sent as ‘Authorised’ to Xero 
 

• The Nett for each invoice line is sent. The GST Status is determined from the General Ledger Code 
associated with the invoice line 
 

• Once an Invoice has been sent to Xero it cannot be edited in Paybiz 
 

• Invoices can be removed in Paybiz by un-invoicing a job/tally sheet 
If this is done you will need to manually delete the invoice in Xero otherwise a duplicate invoice will be 
generated in Xero when the job/tally sheet is invoiced again 
 
 

Receipts: 

• Over/Underpayments less than $1.00 will automatically be sent to the Settlement account for Debtors (G/L 
code 53.0000 in the default General Ledger) 
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Company Details – Configure the Connection to Xero 
 
A Paybiz user needs to Authorise their Paybiz application to “Connect” to a Xero tenant company so the 
information can be exchanged. 
 
This is controlled in the Xero tab of Company Details. 
 
PayBiz main menu > File > Company > Company Details > Xero tab 
 

 
Figure 1: Company Details > Xero tab 

 
The Client ID for Paybiz is: 
 

25CF7044DCCC4C8796574AEF4170F31F 
 

• Enter the Client ID into your Paybiz application and Save 
 

• Double click or hit F8 in the Xero Authorised Token field to choose or add a token 
 

 
Figure 2: Xero Authority setup 

 
  

• Choose a numeric identifier for the Token Key 
 

• Select the SSIoauth2AgentXero option 
 

• Click Setup to open a browser window at the Xero login screen 
 

• Log in to Xero using your Xero credentials 
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• Choose the desired organisation from the Select an organisation drop box and click Allow Access 
 

• Once communication between Xero and Paybiz is complete this message will display: 
 
 

Complete. Please return to the application. 27 January 2022, 10:50:15 

 
 

• Close the browser and return to Paybiz 
 

• The Oauth2 Token screen will now be populated with the integration details 
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Figure 3: Example of a successful Paybiz connection to Xero 

 

• Click Exit 
 

• Click Pick to select the Oauth2 Token. The screen will return to the Xero tab of Company Details 
 

• Click Save on the Company Details screen to save the Xero Authorised Token 
 

• Click Choose Tenant and select the Xero Company to link with Paybiz 
 

• Enter the date to start the Xero Integration 
Invoices and Payments before this date will not be transferred 
 

• Enter the default Xero account code for invoice lines 
Generally this should be the Sales code in Xero (default = 200) 
This code will be used for any invoice lines that use a GL code missing an External Code 
 

• Click Save 
 

 
Figure 4: Completed Xero Configuration 
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Load/Link Xero Contacts - Onboarding 
 
During the initial setup, there is the option to link Contacts from Xero to Debtors in Paybiz. 
You can also create new Paybiz Debtors for Xero Contacts 
 
Click the Load Xero Contacts button on the Xero tab of Company Details 
 

 
Figure 5: Import Xero Contacts 

 
 

 
Button/Action 

 
Description 

 
Auto Link 
 

 
 
List of Xero Contacts 
 
 
 
 
Create All 
 
 

 
Attempt to automatically link the Xero contacts with existing Paybiz Debtors. 
Use the email address to identify any matches. 
If matches are found, they will be moved to the Pending Link tab for review. 
 
Double click on any row to view the Xero Contact details. 
Double click on the Debtor field on the Link Xero Contact window to pick a Paybiz 
Debtors and click Link to manually link the selected contact to the chosen Paybiz 
Debtor (see below). 
 
Click to import all the unlinked contacts from Xero and create them as new Debtors in 
Paybiz. 
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Manually Link Xero Contact 
 

 
Figure 6: Manually link Xero Contact to Paybiz Debtor 

 
Process Pending Links 
 
Click Apply All on the Pending Link tab to create links between the Xero Contacts and Paybiz Debtors. 
 
The rows will move to the Linked tab and the Xero Contact ID will be set as the External ID on the Paybiz Debtor 
record. 
 

 
Figure 7: Pending Links 
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Debtor Setup 
 
PayBiz main menu > Debtors > Debtors > Xero tab 
 

 
Figure 8: Xero tab on Debtor Screen 

 
 

 
Field 

 
Description 

 
Do NOT send to Xero 
 
Postal Address 
Street Address 
 
Set Postal from Address 
 
Copy --> 
 
Xero ID 
 
 
 

 
Set to exclude this Debtor, their contacts and invoices from being sent to Xero 
 
) Address details to send to Xero 
) 
 
Click to attempt to populate the Postal Address from the free text address above 
 
Click to copy the Postal Address to the Street Address 
 
The Xero Client ID returned from Xero when this Debtor is linked/created in Xero 
Removing this will unlink the Debtor. The Debtor will be re-linked when the next 
synchronisation occurs. 
 
 

 

http://www.shebiz.nz/


P.O. Box 78 
CROMWELL 

9342, NZ 
  

  Ph 64 3 445-1345 
   www.shebiz.nz 

 
 

Page 10 of 16 

Debtor Contacts 
 
PayBiz main menu > Debtors > Debtors > Contacts tab 
 

 
Figure 9: Debtor Contact 

 
 
 

• Paybiz Contacts create Contact Persons in Xero 
 

• Debtor Contacts can be used to sent multiple email addresses to Xero 
 

• You must use a separate contact for each additional email address 
 

• Include in emails – Xero – Matches the setting in Xero for Contact Persons and is used to identify recipients 
for Xero Emailed Invoices if Request Invoice Emails is set in the Xero synchronization schedule 

 

• Only First Name, Last Name and Email are sent to Xero 
The other fields are only used in Paybiz 
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Debtor Invoices 
 
PayBiz main menu > Debtors > Debtor Invoices 
 

 
Figure 10: Debtor Invoice - Approved 

 

• Invoices are sent as ‘Authorised’ to Xero 
This is determined by the Approved slider on the Debtor Invoice screen 
 

• Debtor Invoices in Paybiz are Approved by default 
This behaviour can be changed in Company Details > Constants tab 

 

 
Figure 11: Setting on Company Details to Approve Db Invoices by default 

 

• The Nett for each invoice line is sent. The GST Status is determined from the General Ledger Code 
associated with the invoice line 
 

• Once an Invoice has been sent to Xero it cannot be edited in Paybiz 
 

• Invoices can be removed in Paybiz by un-invoicing a job/tally sheet 
If this is done you will need to manually delete the invoice in Xero otherwise a duplicate invoice will be 
generated in Xero when the job/tally sheet is invoiced again 
 

• Invoices that have been sent to Xero will have an External Identifier – this comes back from Xero when a 
Sales invoice is created 
This column can be added to the Debtor Invoice lookup screen if desired to easily identify invoices that 
have been sent 
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Making Invoice Corrections 
 
When payments are received in Xero, the External Identifier for the invoice that is being paid is sent from Xero to 
Paybiz so we can match the payment with the invoice in Paybiz. 
Un-Invoicing deletes the Paybiz invoice. It does not alter the Xero invoice if it has already been sent.  
 

1. If you need to make a change to an invoice that has already been sent to Xero, you can Un-Invoice in 
Paybiz and manually delete the invoice in Xero. 
When the job/tally sheet is invoiced again the new invoice will be sent to Xero and a new External ID will 
be returned to Paybiz. 
 
The danger is if the client then pays on the original Xero invoice the payment will be linked to the 
original invoice external ID. Obviously this will cause a problem trying to import the receipt into 
Paybiz as that external ID no longer exists. 

 
2. Alternatively, you can copy the External ID from the Invoice BEFORE you un-invoice the tally sheet: 

 
a. When the Tally sheet is UN-Invoiced, the External ID of the invoice will display in a separate 

window. 
b. Make the required changes to the tally sheet and re-invoice. On the new invoice paste the External 

ID into the field on the Notes tab of the Debtor Invoice screen. 
c. In Xero manually adjust the corresponding invoice there and send it again. 

The External ID is preserved in this case, so any receipt made will be matched against the correct 
invoice in Paybiz. 

d. Close the separate window with the External ID. 
 
 

General Ledger Setup 
 
PayBiz main menu > Ledger > Analysis Codes 
 

  

 
Figure 12: GL Analysis Code Setup for Xero 

 

• For any GL codes that will be used on an invoice, you need to set the External Code to the corresponding 
code in the Xero Chart of Accounts. 
 

• If the External Code is missing, the Default Xero Sales Account Code defined on the Xero tab of Company 
Details will be used. 
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Xero Interface Synchronisation 
 
PayBiz main menu > File > System > System Functions 
 

 
Figure 13: Xero Interface Synchronisation example 

 
 

 
Field 

 
Description 

 
Start On       At 
Frequency    Minutes 
 
Note 
 
Requires GUI 
 
 

 
) Enter the schedule frequency details 
) 
 
Enter any relevant notes 
 
Leave NOT set 

 
Select Company 
 
 
Send Debtors to Xero 
 

 
Select the Paybiz company. 
Multi-company systems will need to create a separate schedule for each company. 
 
New Debtors will create new Contacts in Xero 
New Debtor Contacts will create new Contact Persons in Xero 
Changes to Debtors or Debtor Contacts will update the linked Contact in Xero 
 
 

 Continued… 
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Field 

 
Description 

 
Send Invoices to Xero 
 
Request Invoice Emails 
 
Get Payments from Xero 
 
Days Back for Changes 
 
 

 
New Debtor invoices in Paybiz will create new Invoices in Xero 
 
Instructs Xero to send Invoice Emails for the new invoices 
 
Retrieve payments entered into Xero and allocate to the linked invoices in Paybiz 
 
The number of days to look back for invoices in Paybiz and receipts in Xero 

 
Email Notifications 
 

 
Select the desired emailing notifications and the email address for these 

 
 

Synchronisation Log File 
 
PayBiz main menu > File > System > System Functions > View System Function Log 
 

 
Figure 14: System Function Log 

 
Errors show with a red background. 
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Common Errors 
 
 

 
Error 
 
 
 
 
 
Cause 
 
Solution 

 
Unable to connect to Xero. 
Call failed, response status=401    or    Call failed, response status=403 
Or 
Exception Code 1090 = Attempted access via null object reference in 
getAccessTokenRequestErrorMessage (333) 
 
Xero security Token has expired. 
 
Refresh the token: 

• PayBiz main menu > File > Company > Company Details > Xero tab 

• Double click in the Xero Authorised Token field 

• Display the selected token 

• Click the Setup button to open a browser window at the Xero login screen 

• Log in to Xero using your Xero credentials 

• Complete the Xero 2-Factor Authentication 

• A Xero web page will open with    Paybiz wants Access to: 

• Select the relevant Xero Company and click Allow Access 
 

 
Error 
 
 
Cause 
 
 
Solution 
 
 
 

 
The contact name COMPANY LTD is already assigned to another contact. The contact name must 
be unique across all active contacts. 
 
There is an active Xero contact with this name that is not linked to the Paybiz Debtor with the 
same name. 
 
Change the Contact name in Xero so the new Debtor in Paybiz can be created in Xero. 
OR 
Go to Load Xero Contacts on the Xero tab of Company Details and link the contact to the Paybiz 
debtor. 
 

 
Error 
 
 
Cause 
 
 
Solution 
 
 

 
Unable to send debtor 1630: The Account Number already exists. Please enter a different Account 
Number. 
 
The Paybiz debtor with this account number does not have a Xero ID or does not match the 
contact in Xero with this account no. 
 
Check in both Xero and Paybiz for account number 1630 and correct the details as needed. 

 
Error 
 
 
Cause 
 
Solution 
 

 
Unable to send debtor 1580:The specified contact details matched an archived contact. Archived 
contacts cannot currently be edited via the API. 
 
The Xero Contact with account no 1580 has been archived. 
 
Un-Archive the Contact in Xero. 

 Continued… 
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Error 
 
Cause 
 
Solution 
 

 

Unable to send invoice for debtor 400:One or more line items must be specified 
 
There is an invoice in Paybiz with no lines. 
 

• In Paybiz go to Debtors > Debtors 

• Change the filter to All Debtors by Account No 

• Display debtor 400 

• Click Details button and view the Transactions History 

• Check the invoices for one with no lines and either delete or correct it. 
 

 
Error 
 
 
 
Cause 
 
 
 
 
Solution 

 
Unable to create receipt for external ID cd791e42-3807-4548-8e71-f3ff878eaff8 - No Invoice found 
for external ID: 0667c66e-946e-4707-a2ff-a8d91c555510, Xero Contact: SOMETHING FARMS, 
Amount: 7654.65 
 
There is no invoice in Paybiz that matches the Xero invoice for the receipt. 

I. The Tally Sheet may have been un-invoiced and a new invoice created with a new Xero ID. 
 

II. The receipt may not for a Paybiz invoice. 
 

I. Check for duplicate invoices in Xero. Either: 
a. Process the receipt manually in Paybiz Or: 
b. Update the Xero ID of the matching Paybiz Invoice to the invoice external ID in the 

log (0667c66e-946e-4707-a2ff-a8d91c555510) 
 

II. Ignore if the receipt is not related to a Paybiz invoice. 
 

 
Error 
 
 
 
Cause 
 
Solution 
 
 
 

 
Unable to create receipt for external ID 6003edd8-8c52-4e2f-b560-1d70edc639fe - No Debtor found 
for external ID: b0e96a95-e8e5-4faa-88e7-cbd8cc65beab, Xero Contact: TELECOMS COMPANY PTY 
LTD, Amount: 1234.00  
 
There is no Paybiz debtor with that Xero ID. 
 
Ignore if this is not a Paybiz related receipt. 
Otherwise, check the Xero Contact has the Paybiz account no and the Paybiz Debtor has the Xero 
ID that matches the external ID in the log (b0e96a95-e8e5-4faa-88e7-cbd8cc65beab). 

 
Error 
 
Cause 
 
Solution 

 
Unable to create receipt for external ID 96bc2c8a-2f49-4000-a6b9-9622491f30ce - Period is closed 
 
The receipt cannot be saved in Paybiz because the date of the receipt is in a closed month. 
 

• Go to Tools > Period Balances and display the relevant Period. 

• Click Open Period 

• Click System Wide Period Open 

• Click Open 
 
Remember to close the period again once the synchronisation has completed. 
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